首页 > 代码修改 > 读者墙插件和5.0存在兼容性问题
2012
11-12

读者墙插件和5.0存在兼容性问题

今天一早,打开博客一看所有日志都变成了如下图片所示的样子,没有了正文,清一色的标题党!

读者墙插件和5.0存在兼容性问题 - 第1张  | 心岛博客

让我郁闷了好半天,因为前几天因为插件没有及时更新的原因导致过一次错误就是后台无法正常上传附件,所以此次我的解决思路仍然是这样,先将后台中插件逐一禁用后启用,发现了问题的所在那就是读者墙V4.2版本的问题,可能只是在我使用的模版中发生了类似状况,而别人模版中未曾出现,具体情况不得而知,所以我直接将插件禁用后发现有的页面还是不行,有几篇好了,所以我干脆打开了模版源文件echo_log.php,发现原来的内容函数<?php echo $log_content; ?>被替换成了<?php doaction(“$xiaosonglog”  $log_content; ) ?>(这个是我根据回忆写的,大体就这个样式,当然可能和原来一样的),我将此参数替换还原后网页显示正常,同时还需要替换系page.php文件,一切宛如初相见!

以上为本人解决此次“标题党”事件的过程,由于本人并不了解php,所以只是以排除的方式进行查找错误原因,希望小松老大能够及时修正读者墙插件!

最后编辑:
作者:xindao
这个作者貌似有点懒,什么都没有留下。

读者墙插件和5.0存在兼容性问题》有 2 条评论

留下一个回复

你的email不会被公开。